Arreglar repositorios de Getdeb

Desde hace algunas semanas no funcionan los repositorios principales de getdeb, por lo que cada vez que actualicemos nos avisará que no funcionan y nos saldrá un aviso diciendo que la información de actualización no se actualiza desde hace un chorro de días. La solución es cambiar los repositorios de getdeb por un mirror. Podemos hacerlo fácilmente pegando este comando en el terminal:

Si agregasteis los repositorios mediante el paquete .deb de la página de getdeb:
sudo rm /etc/apt/sources.list.d/getdeb.list && sudo sh -c "echo 'deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps' >> /etc/apt/sources.list.d/getdeb.list"

Si lo hicisteis manualmente, tendréis que ir a Administración->Orígenes del software->Otro software, eliminad deb http://archive.getdeb.net/ubuntu lucid-getdeb apps y añadid deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb apps

Actualización: Para playdeb:
sudo rm /etc/apt/sources.list.d/playdeb.list && sudo sh -c "echo 'deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games' >> /etc/apt/sources.list.d/playdeb.list"
Share on Google Plus

About Eduardo Parra


12 comentarios:

Hori dijo...

a mi hace unos pocos días que me pasa. Lo he actualizado tal y como indicas pero continúa saliéndome diversos erroreste adjunto los repositorios que me da error a ver si se te ocurre algo

http://archive.getdeb.net/ubuntu/dists/lucid-getdeb/Release.gpg
http://archive.getdeb.net/ubuntu/dists/lucid-getdeb/games/i18n/Translation-ca.bz2
http://archive.getdeb.net/ubuntu/dists/lucid-getdeb/apps/source/Sources.gz
http://archive.getdeb.net/ubuntu/dists/lucid-getdeb/games/binary-i386/Packages.gz

Hori dijo...

Me contesto a mi mismo. He seguido las instrucciones del siguiente enlace:
http://blogguino.blogspot.com/2010/06/repositorios-de-getdeb-activos.html

He eliminado el repositorio del codigo fuente de apps de getdeb y el de juegos y he añadido el siguiente

deb http://mirrors.dotsrc.org/getdeb/ubuntu lucid-getdeb games

Soker dijo...

@Hori, eso era porque no habia puesto el mirror de playdeb (falta de tiempo), ya esta puesto

Hori dijo...

@soker, gracias

Anónimo dijo...

He realizado lo indicado por tí, pero resulta que me dice en consola
W: GPG error: http://mirrors.dotsrc.org lucid-getdeb No se pueden verificar las siguientes firmas debido a que la llave pública no está disponible: NO_PUBKEY A8A515F046D7E7CF

entonces como solucionar el problema?

gracias soker

Soker dijo...

@Anonimo para agregar la clave tienes que esperarte a que arreglen la pagina de getdeb, y agregarla con:

wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

Fer dijo...

tengo este problema y no se como solucionarlo
http://ppa.launchpad.net lucid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 7D36DED1FB53CE24

les agradeceria por su ayuda.

Fer dijo...

es completamente este
W: Error de GPG: http://ppa.launchpad.net lucid Release Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY 7D36DED1FB53CE24

Soker dijo...

@Fer Esto te lo debería de arreglar

gpg --keyserver subkeys.pgp.net --recv-key FB53CE24 && gpg -a --export $PUBKRY | sudo apt-key add -

Soker dijo...

@Fer Esto te lo debería de arreglar

gpg --keyserver subkeys.pgp.net --recv-key FB53CE24 && gpg -a --export $PUBKRY | sudo apt-key add -

Soker dijo...

@Anonimo para agregar la clave tienes que esperarte a que arreglen la pagina de getdeb, y agregarla con:

wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

Soker dijo...

@Hori, eso era porque no habia puesto el mirror de playdeb (falta de tiempo), ya esta puesto