martes, 17 de septiembre de 2013

Banshee no funciona al actualizar mono a la version 3.2 en Archlinux


Esta tarde he actualizado mono de la versión 3.0.12 a la 3.2 y después de hacerlo al abrir banshee me daba el siguiente error:
Got a SIGSEGV while executing native code. This usually indicates a fatal error in the mono runtime or one of the native libraries  used by your application.
La solución (de momento) es desactualizar mono a la versión anterior, primero comprueba que tienes una versión anterior en la cache de paquetes de pacman:
ls /var/cache/pacman/pkg | grep mono-3.0
Y después desactualiza mono:
sudo pacman -U /var/cache/pacman/pkg/mono-3.0.12-1-x86_64.pkg.tar.xz

Nota: Si tienes otra versión de mono en la cache cambia el nombre por el que corresponda.
Nota 2: En el caso de no tener el paquete de versiones mas viejas de mono puedes ver otras formas de desactualizar aqui.

Listo! Ya puedes volver a disfrutar de Banshee.

Actualización:  La versión 3.2.3 de mono funciona perfectamente con Banshee.
Eduardo Parra Estudiante de Ingeniería Infmática